• 1

Read this first!

We do not monitor these forums. The forum is provided to exchange information and experience with other users ONLY. Forum responses are not guaranteed.

However, please submit a ticket if you have an active subscription and wish to receive support. Our ticketing system is the only way of getting in touch with RSJoomla! and receiving the official RSJoomla! Customer Support.

For more information, the Support Policy is located here.

Thank you!

TOPIC: "Read More" Link not shown correct

"Read More" Link not shown correct 4 years 2 months ago #31899

  • c.krug
  • c.krug's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
Dear all,

I try to add "Read more" Links to my Blog entries but they are not shown on the places I put them to.

RSBlog Options:
Frontend: Enable Readmore link: Yes
Basic: Truncate Blog Posts: --> no matter what I insert, I tried "empty", 0, 10, 50, 1000

Read On link is shown if Truncate is set to any number. But it is only shown after that account of letters - not at the place I added it to.

Did I miss something?
Thanks for a quick help
Best wishes
Claudia
The administrator has disabled public write access.

"Read More" Link not shown correct 4 years 2 months ago #31908

  • cosmin.cristea
  • cosmin.cristea's Avatar
  • OFFLINE
  • RSJoomla! Official Staff
  • Posts: 756
  • Thank you received: 141
This option should be used if you want to provide a consistent look to your blog post listings. If you do not want to use this, leave the input field empty. Let me know if this issue persists.

More information can be found here:
https://www.rsjoomla.com/support/documentation/rsblog-/getting-started/configuration.html
My help is not official customer support. To receive your support, submit a ticket by clicking here
The administrator has disabled public write access.

"Read More" Link not shown correct 4 years 2 months ago #31960

Hi

I can confirm that in RSBlog!Configuration>Post Options>Front End, the 'Enable Readmore link' is selected and active.

I can also confirm that RSBlog!Configuration>Basic>Blog options>Truncate Blog Posts is left blank.

If I insert a read more link into a blog post manually, it seems to be ignored.

Is anyone else having this problem?

Thanks

J
The administrator has disabled public write access.

"Read More" Link not shown correct 3 years 1 month ago #35783

  • teddyboy
  • teddyboy's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Sorry for a belated reply, but I too am having this issue.

It seems that RSBlog does not obey the Joomla rules when displaying the blog posts within the component display. It only considers the number of words in "Truncate Blog Posts" option in the Global Configuration in determining where to place the Read More wording and not where the read-more break is placed in the article.

To my mind this is a major oversight, but seems to be perpetuated in subsequent issues. This may be because coding this publishing option into theRSBblog component may be too difficult.

I agree with you that obeying the Joomla convention would be best. This is a major obstacle to using the component I think.

Ted
The administrator has disabled public write access.

"Read More" Link not shown correct 2 years 1 month ago #37332

Hello,

Is there any improvement about this read more bug ?

Regards

ED
The administrator has disabled public write access.

"Read More" Link not shown correct 2 years 1 month ago #37343

  • madalina
  • madalina's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
Hello,

There are two approaches that will make the "Read more" link properly display:

1. "Truncate Blog Posts" option: in the RSBlog! Configuration section (accessed through the "Option" button, upper-right corner), in the "Basic" tab scroll down to "Blog Options" and fill in the "Truncate Blog Posts" with the number of characters that will be automatically displayed before the "Read More" link.
2. - Leave the "Truncate Blog Posts" field empty;
- RSBlog! Configuration > Frontend > Post Options > set the "Enable Readmore link" option to Yes;
- While editing your RSBlog! Menu Item in the "Options" tab set to Yes the "Only Display Intro Texts" option.

Regards!
The administrator has disabled public write access.
The following user(s) said Thank You: eric.deronzier6
  • 1

Read this first!

We do not monitor these forums. The forum is provided to exchange information and experience with other users ONLY. Forum responses are not guaranteed.

However, please submit a ticket if you have an active subscription and wish to receive support. Our ticketing system is the only way of getting in touch with RSJoomla! and receiving the official RSJoomla! Customer Support.

For more information, the Support Policy is located here.

Thank you!