Error when checking RSFirewall! and Joomla! versions

In some cases, the RSFirewall! CPanel Module's RSFirewall! and Joomla! areas return parsererror instead of information regarding RSFirewall!'s and Joomla!'s update status. This also applies for the System Check when performing the same verifications.

 

The issue is usually generated by the fact that the fopen PHP resource and the cURL HTTP requests library are disabled.

To verify if you find yourself in this situation, please head to System > System Information > PHP Information and:

  • Look for the curl section. If curl is switched off, its section should not be present.
  • Scroll down to the Core section and verify if allow_url_fopen is set to Off.

If any of the cases presented above apply to you, please contact your hosting provider and ask them to enable curl and allow_url_fopen for your website.


One person found this article helpful.


Was this article helpful?

Yes No
Sorry about that

You Should Also Read

System Version Check - Checking if you have the latest Joomla! version

No HTTP response code found

System Version Check - Checking if you have the latest RSFirewall! version

Connection Timeout when checking fo Joomla and RSFirewall versions