• 1

Read this first!

We do not monitor these forums. The forum is provided to exchange information and experience with other users ONLY. Forum responses are not guaranteed.

However, please submit a ticket if you have an active subscription and wish to receive support. Our ticketing system is the only way of getting in touch with RSJoomla! and receiving the official RSJoomla! Customer Support.

For more information, the Support Policy is located here.

Thank you!

TOPIC: Email cloaking incompatible with RSform!

Email cloaking incompatible with RSform! 13 years 6 months ago #2624

  • oldrock
  • oldrock's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 8
A standard contact form including an email address (pre-entered by the form) works fine in test mode or if linked directly to a menu. When linked in an article the standard Joomla email cloaking interferes with the email field. The pre-entered address is replaced with the raw javascript cloaking code (I can't included it here because it causes the post to be rejected).

Even if I remove the pre-entry code, the same thing happens if there's an error on the form when the form is re-displayed with the error messages.

Any way around this?
The administrator has disabled public write access.

Re:Email cloaking incompatible with RSform! 13 years 5 months ago #2765

  • sonome
  • sonome's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
I've just come across this same problem, and (I think) have solved it.

In the Form Style tab for your form, insert the tag {emailcloak=off} just before the tag {formfields}.

It seems to do the trick for me, let me know how you get on!
The administrator has disabled public write access.

Re:Email cloaking incompatible with RSform! 13 years 4 months ago #3093

This works also:

Put {emailcloak=off} before {rsform 1} in your content.
I.e.:
{emailcloak=off}{rsform 1}
The administrator has disabled public write access.

Re:Email cloaking incompatible with RSform! 13 years 3 months ago #3675

  • sbooks
  • sbooks's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
these didn't work for me, and I'm using the latest release of RsForms!Pro. com_rsform_pro1.0.1-for-joomla1.0.x.r14.
The administrator has disabled public write access.

Re:Email cloaking incompatible with RSform! 13 years 1 month ago #4511

  • madhangc
  • madhangc's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
Even i use rsformpro.. what i did was <!--{emailcloak=off} --> in the content page. It works well and good.
hope it helps.
madhan
Last Edit: 11 years 10 months ago by octavian.
The administrator has disabled public write access.

Re:Email cloaking incompatible with RSform! 11 years 10 months ago #9035

  • studio9
  • studio9's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
I had a problem with the form showing but not doing anything when I clicked submit.

The solution is disabling the Joomla Cache (from the Global Configuration and the System Cache plugin), clear the cache (Tools > Clean Cache) and try it again.
The administrator has disabled public write access.

Email cloaking incompatible with RSform! 7 years 4 months ago #27791

  • joris3
  • joris3's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
This worked form me but the problem is that on a contact page with an email showed there is no email cloaking anymore.

That is the reason why i have enabled the cloaking.

Does anybody know a workaround? ony not cloak in the form but on the rest of the page cloak?
The administrator has disabled public write access.
  • 1

Read this first!

We do not monitor these forums. The forum is provided to exchange information and experience with other users ONLY. Forum responses are not guaranteed.

However, please submit a ticket if you have an active subscription and wish to receive support. Our ticketing system is the only way of getting in touch with RSJoomla! and receiving the official RSJoomla! Customer Support.

For more information, the Support Policy is located here.

Thank you!